Support to Information and Communication Technology

Otomatis Backup Mikrotik ke Email

Iseng-iseng tapi mungkin bermanfaat sangat saya meluangkan waktu untuk mencoba konfigurasi membackup semua konfigurasi router disalah satu perusahaan swasta yang otomatis mengirimkan hasil backupannya ke email saya. jadi saya tidak perlu repot2 untuk membackup sendiri. langsung saja kita simak langkah2nya:

1. Remote menggunakan Winbox
2. Pilih Tools > Email
3. Input
Server : isi dengan ip smtp server anda, disini saya menggunakan gmail.
Untuk mengetahui ip smtp server anda bisa mengeceknya dengan utilitas ping ke smtp.gmail.com dan smtp.mail.yahoo.com
Port : 25 (default)
From : isi dengan alamat email penerima hasil backup
User : isi dengan alamat email pengirim hasil backup
Password : isi dengan password email pengirim

Contoh seperti gambar dibawah ini
Gambar diatas itu saya menggunakan ip smtp.gmail.com dengan port default yaitu 25. Saya setting from untuk dikirimkan ke gmail saya dari user gmail saya. Bisa diganti jiika anda ingin mengganti dengan email yahoo atau yang lainnya.

4. Apply > Ok
5. Pilih System > Scripts > Klik +
6. Input
Name : isi dengan nama script yang diinginkan
Policy : centang semua
Source : isi dengan script seperti dibawah ini atau bisa DOWNLOAD scriptsnya dan copas
#----deklarasi variable------------------------------------------------
#:local ts [/system clock get time]
#:set ts ([:pick $ts 0 0].[:pick $ts 3 5].[:pick $ts 6 8])
:local ds [/system clock get date]
:set ds ([:pick $ds 7 11].[:pick $ds 0 3].[:pick $ds 4 6])
:local identitasRouter [/system identity get name];
:local emailTujuan [/tool e-mail get from];
:local seriMikrotik [/system resource get board-name];
#--------------------------------------
#-----Backup keseluruhan---------------
:local FileBackup ($identitasRouter.$seriMikrotik."-semua-".$ds.".backup")
/sys backup save name=$FileBackup;
#-----Mengirim email-------------------
:delay 30s
:log info "Sedang mengirim email, silahkan tunggu beberapa detik..."
/tool e-mail send subject=$FileBackup body=$FileBackup to=$emailTujuan tls=yes file=$FileBackup
:log info "Email sudah terkirim..."
#--------------------------------------
#-----menghapus -----------------------
:delay 120s
:if ([:len [/file find name=$FileBackup]] > 0) do={/file remove $FileBackup}
:log info "$FileBackup telah dihapus..!"
Penjelasan script diatas :
· Membuat backup berdasarkan nama identitas router berikut tanggal dan jam saat proses backup
· Setelah backup selesai kemudian akan mengirimkannya melalui email yang telah ditentukan di Email setting
· Tersedia delay 10 detik untuk memberi kesempatan kepada router mengirim email, setelah itu file backup yang kita buat akan di delete dari file list yang bertujuan agar hardisk mikrotik kita tidak cepat penuh gara-gara file backup.
· Proses tersebut kemudian akan dicatat di system log

Contoh seperti gambar dibawah ini
Gambar diatas saya input nama scriptnya yaitu backup-semua dan saya centang semua dibagian policy lalu saya copy pastekan script yang ada diatas di kotak source.

7. Apply > Ok
8. Pilih System > Scheduler > Klik +
9. Input
Name : isi dengan nama scheduler yang di inginkan
Start Date : isi dengan tanggal untuk perhitungan awal pembackupan
Start Time : isi dengan waktu untuk perhitungan awal pembackupan
Interval : isi dengan berapa lama hari untuk pembackupan
On Event : isi dengan nama file scripts yang tadi sudah kita buat
Policy : centang semua

Contoh seperti gambar dibawah ini
Gambar diatas saya beri nama schedulernya yaitu semua dan saya input startdate sesuai jam pembuatan schedule dan start time saya input jam 6 pagi, untuk interval saya setting ke 7d = 7 Hari dalam bahasa inggris yaitu 7 Day untuk jangka waktu pembackupan dan On Event saya isikan nama file script yang saya buat tadi “HARUS SAMA”.

10. Apply > Ok
11. Test dengan Run Scripts yang terdapat di menu Script List seperti gambar dibawah ini

0 comments:

Posting Komentar