Support to Information and Communication Technology

Simple Queue, Memisahkan Bandwidth Internasional (OpenIXP) dan Lokal (IIX)

Disini saya akan menjelaskan bagaimana caranya untuk memisahkan bandwitdh internasional dengan lokal yang akan saya coba di fasilitas Queue yaitu Simple Queue.

Saya akan mencobanya menggunakan RouterBoard 450G yang mendapatkan
IP WAN = 10.10.10.254/23
dan saya konfigurasi
IP LAN = 192.168.1.99/24 Seperti gambar dibawah ini.
Sesuaikan alokasi ip diatas dengan ip yang ada di jaringan anda. langsung saja kita lakukan konfigurasi untuk pemisahan bandwitdhnya.

1. Kita harus melakukan update nice terlebih dahulu, untuk cara pengupdatean nice lihat di artikel saya ini
2. Jika sudah kita update maka kita akan langung mengkonfigurasi manglenya
Mangle Traffic IIX
/ip firewall mangle
add chain=forward action=mark-connection new-connection-mark=cont-iix passthrough=yes protocol=!icmp src-address-list=localnet dst-address-list=nice comment=IIX
add chain=forward action=mark-connection new-connection-mark=cont-iix passthrough=yes protocol=!icmp src-address-list=nice dst-address-list=localnet
add chain=prerouting action=mark-packet new-packet-mark=iix passthrough=yes connection-mark=cont-iix

Mangle Traffic OpenIXP
/ip firewall mangle
add chain=forward action=mark-connection new-connection-mark=cont-int passthrough=yes protocol=!icmp src-address-list=localnet dst-address-list=!nice comment=OpenIXP
add chain=forward action=mark-connection new-connection-mark=cont-int passthrough=yes protocol=!icmp src-address-list=!nice dst-address-list=localnet
add chain=prerouting action=mark-packet new-packet-mark=int passthrough=yes connection-mark=cont-int
Maka akan tampak seperti gambar dibawah ini, untuk pengcopyan script manglenya bisa didownload disini

3. Kita konfigurasi address list localnetnya karena di konfigurasi mangle tadi kita menggunakan address-list localnet. dan kita harus inputkan ip lokal kita
/ip firewall address-list
add list=localnet address=192.168.1.0/24
Sesuaikan dengan ip lokal jaringan anda maka tampilannya akan seperti gambar dibawah ini

4. Lalu kita konfigurasikan Simple Queuenya, disini saya mengkonfigurasikan Simple Queuenya menggunakan Parent-Child yang mempunyai 10 client. dan jika anda ingin menambahkannya bisa mengedit script dibawah ini.
Membuat Parent Simple Queue
/queue simple
add name="Parent-IIX" target-addresses=192.168.1.0/24 interface=all parent=none packet-marks=iix direction=both priority=8 queue=default/default limit-at=0/0 max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="Parent-OpenIXP" target-addresses=192.168.1.0/24 interface=all parent=none packet-marks=int direction=both priority=8 queue=default-small/default-small limit-at=0/0 max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small

Membuat Child Simple Queue
add name="SK1-PC-IIX" target-addresses=192.168.1.204/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR-SERVER-IIX" target-addresses=192.168.1.100/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 
add name="KOPKAR7-IIX" target-addresses=192.168.1.31/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 
add name="KOPKAR6-IIX" target-addresses=192.168.1.30/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR5-IIX" target-addresses=192.168.1.23/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR4-IIX" target-addresses=192.168.1.14/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 
add name="KOPKAR3-IIX" target-addresses=192.168.1.22/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 
add name="KOPKAR2-IIX" target-addresses=192.168.1.12/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR1-IIX" target-addresses=192.168.1.15/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="SK2-PC-IIX" target-addresses=192.168.1.205/32 interface=all parent=Parent-IIX packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/512k max-limit=2M/2M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 

add name="SK1-PC-OpenIXP" target-addresses=192.168.1.204/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR-SERVER-OpenIXP" target-addresses=192.168.1.100/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR7-OpenIXP" target-addresses=192.168.1.31/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR6-OpenIXP" target-addresses=192.168.1.30/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR5-OpenIXP" target-addresses=192.168.1.23/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR4-OpenIXP" target-addresses=192.168.1.14/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR3-OpenIXP" target-addresses=192.168.1.22/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR2-OpenIXP" target-addresses=192.168.1.12/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
add name="KOPKAR1-OpenIXP" target-addresses=192.168.1.15/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small 
add name="SK2-PC-OpenIXP" target-addresses=192.168.1.205/32 interface=all parent=Parent-OpenIXP packet-marks="" direction=both priority=8 queue=pcq-up/pcq-down limit-at=256k/256k max-limit=1M/1M burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s total-queue=default-small
Maka akan tampak seperti gambar dibawah ini, untuk pengcopyan script Simple Queue bisa didownload disini

Perhatikan script yang berwarna merah diatas !!!
Saya sengaja menandai sebagian script itu berwarna merah karena simple queue diatas tersebut saya konfigurasi dengan PCQ yaitu berfungsi untuk pembagian bandwidth secara adil dan untuk bagaimana cara konfigurasi PCQ akan saya jelaskan di artikel yang akan saya buatkan nanti. sementara anda bisa mengubah tulisan berwarna merah tadi menjadi seperti script dibawah ini

queue=default-small/default-small limit-at=0/0
Silahkan dicoba browsing atau download di server lokal maupun internasional, apakah ada traffic di simpleque parent lokal maupun internasional jika iya maka pemisahan bandwidth internasional dan lokal anda sudah berhasil.

2 comments:

Oky Dwi Prasetyo mengatakan...

gan tong dong via winboxnya biar lebih gampang, bingung

khoerul anwar mengatakan...

http://anwar-network.blogspot.com/

Posting Komentar